MERLIC の設定

ユーザーインターフェースをカスタマイズすると、選択した内容が MERLIC5.ini ファイルに保存されます。MERLIC5.ini ファイルの設定を直接変更する方法については、MERLIC INI ファイル を参照してください。

パネルの配置変更

MERLIC Creator のパネルは、すべてウィンドウの特定部分に移動してドッキングできます。そのため、作業時に使いやすい場所に移動することができます。複数のパネルを重ねて配置し、タブのように使用することもできます。

  1. 移動するパネルのタイトルにマウスを合わせます。
  2. ドッキングするウィンドウの部分にパネルをドラッグします。パネルの移動中は、青色にハイライトされるエリアがパネルがドッキングされる位置を表します。
  3. ユーザーインターフェースで目的のエリアがハイライトされたら、パネルを新しい位置にドロップしてください。

設定の実行

MERLIC 環境設定ダイアログでは、MERLIC のユーザーインターフェース設定やログのオプションなどさまざまな設定を定義することができます。

ダイアログを開くには、MERLIC Creator でメニュー「編集 → 設定」をクリックします。利用可能な設定は次のタブカードで示されます。

「全般」タブと「色」タブは、すべてのユーザーとすべてのタイプの MERLIC ライセンスに表示されます。「カスタムツール」タブは、ライセンスでカスタム MERLIC ツールの実装と使用が許可されている場合にのみ表示されます。

以下の項では、各タブで利用できるオプションについて説明します。環境設定によっては、変更を有効にするために MERLIC の再起動が必要になります。使用できるオプションのデフォルト設定は、「 デフォルトを復元」ボタンで復元できます。ただし、復元できるのはアクティブなタブカードの設定のみです。

全般 タブ

「全般」タブでは、ユーザーインターフェースの設定の調整、アップデート通知ダイアログの無効化、ツールフロー オプションの有効化および、ログオプションの定義ができます。

ユーザーインターフェイス

ユーザーインターフェイスのオプション

説明

言語

このオプションでは、ユーザーインターフェースの言語を変更できます。デフォルトで、MERLIC は、MERLIC のインストールプロセスで選択した言語を使用します。ドロップダウンメニューのリストで別の言語を選択することもできます。言語の変更を適用するために別の言語が選択された場合、MERLIC を再起動する必要があります。

以下の言語を使用できます:

  • 英語
  • ドイツ語
  • 日本語
  • 簡体字中国語

ライン幅

このオプションでは、easyTouch で表示される領域の境界幅など、MERLIC で表示されるラインの幅を調整できます。ピクセル単位で定義します。ツールに新しいライン幅が適用されるのは、調整後に追加されたツールのみです。

通知

このカテゴリのオプションを使用すると、新しいアップデートが利用可能になったとき、MERLIC が起動時にその通知ダイアログを表示するかどうかを選択できます。デフォルトでは、通知は有効になっています。アップデートが利用可能な場合は、MERLIC バージョンをアップデートするまで、アップデートがあることを起動毎に通知ダイアログでお知らせします。ただし、通知ダイアログ自体でチェックを外して、または「設定」ダイアログで、通知を無効化できます。

ディープラーニングのオプション

このプロパティを使用すると、NVIDIA® CUDA® Deep Neural Network ライブラリ (cuDNN) によって動的最適化を有効または無効にすることができます。

この最適化は、ディープラーニング技術を搭載した MERLIC ツール (例: 異常を検出) を指します。

デフォルトでは、各チェックボックスは有効になっています。つまり、追加の最適化は実行されません。最適化を有効にするには、チェックボックスのチェックを外します。最適化は、MERLIC ツールで処理ユニットとして GPU を選択するときに実行されます。選択した GPU の能力によっては、有効な最適化にかなりの時間がかかる場合がありますが、通常は推論パフォーマンスが向上し、サイクルタイムが短縮されます。最適化により、以下の処理に必要な時間が改善されます:

  • ディープラーニング技術を搭載した MERLIC ツールを含む MVApps の読み込み
  • ディープラーニング技術を使用する MERLIC ツールを構成する場合:
    • ツールでトレーニングモードが利用可能であれば、トレーニングデータの適用
    • 異なるモデルファイルの選択
    • 処理ユニットの GPU への設定

cuDNN 最適化を使用する場合は、GPU のドライバーを最新バージョンに更新してください。そうでない場合、cuDNN ライブラリによる最適化がサポートされない可能性があります。 この設定を変更した場合は、MERLIC を再起動する必要があります。

表示オプション

このカテゴリのオプションを使用すると、MERLIC が最後の反復で実行されなかったツールを強調表示するかどうかを選択できます。詳細については、「ツールフロー」を参照してください。

ログオプション

ログファイルの情報は、エラーを特定し、プロセス統合を使用して MERLIC で交換されるデータを確認するために非常に役立ちます。

ログオプション

説明

最低ログレベル

このプロパティでは、使用されるログレベルを定義します。一般的に、指定されたレベルのメッセージの記録には、それよりも厳しいレベルのすべてのメッセージが含まれます。以下のログレベルを使用可能です:

  • なし: メッセージは記録されません。
  • 重大: 重大なメッセージのみが記録されます。たとえば、MERLIC のクラッシュを引き起こすエラーなど。
  • エラー: 重大度が「重大」および「エラー」のメッセージのみが記録されます。たとえば、MERLIC ツールのエラーメッセージなど。
  • 警告: 重大度が「重大」、「エラー」、および「警告」のメッセージが記録されます。たとえば、ツールでの問題を示すメッセージなど。
  • 情報: 重大度が「重大」、「エラー」、「警告」、および「情報」のメッセージが記録されます。すなわち、重大ではない一般的な情報を示すメッセージなど。
  • trace: 重大度が「重大」、「エラー」、「警告」、「情報」、および「trace」のメッセージが記録されます。すなわち、警告またはエラーメッセージの状況を理解するうえで役に立ちそうな詳細情報のメッセージなど。

ログファイルパス

このプロパティでは、ログファイルの保存先ディレクトリのパスを定義します。 ボタンを使用して、ログファイルの場所を選択します。

ログファイルの最大数

このプロパティは、ログファイルのどれかが構成市最大サイズを超えたときに、MERLIC の実行中に最近作成されてログディレクトリに保存されるログファイル数を定義します。ログファイルは古いログファイルから削除されます。

ログファイルのどれも構成した最大サイズを超えなければ、ログフォルダー内のログファイル数は制限されません。また、ログフォルダーには、現在作成中のログファイルが保存されます。

ログファイルの最大サイズ

このパラメーターでは、ログファイルの最大サイズをバイト単位で定義します。ログファイルの最大サイズに達すると、MERLIC は新しいメッセージを新しいファイルに記録し始めます。

最小値:1 048 576 = 1 メガバイト

詳細については、「MERLIC INI ファイル」を参照してください。

色 タブ

タブ「色」では、グラフィックウィンドウにおける可視化で使用するさまざまなデフォルト色を変更できます。例、easyTouch プレビューのハイライト色など。

デフォルトでは関心領域 (ROI) がハイライトされ、その領域が高い透明度で描画されます。これは 2 色のアイコンで表示されます。

さまざまな色設定の詳細については、MERLIC INI ファイル ページの [色] セクションを参照してください。

カスタムツール タブ

タブ「カスタムツール」では、カスタムツールのデバッグオプションを有効にしたり、カスタムツールや追加のプロシージャの場所を指定したりできます。

「カスタムツール」タブは、MERLIC ライセンスにアドオン「Extension Tools」が含まれている場合のみ、「設定」ダイアログに表示されます。MERLIC ライセンスパッケージの詳細については、www.mvtec.com を参照してください。

デバッグオプション

このカテゴリのオプションを使用すると、カスタム MERLIC ツールにリモートデバッグモードを使用できます。

デバッグオプション

説明

HDevelop のリモートデバッグを有効にする

このオプションにより、カスタム MERLIC ツールのリモートデバッグの有効化/無効化ができます。このオプションが有効になっている場合、HDevelop デバッグサーバーは、MERLIC の起動時に自動的に起動します。デフォルトでは、このオプションは無効になっています。

HDevelop デバッグポート

このオプションにより、HDevelop デバッグポートを指定できます。デフォルトのポート番号は 57786 です。

カスタム MERLIC ツールのデバッグに関する詳細については、「MERLIC ツール開発マニュアル」の「HDevelop のデバッグツール」を参照してください。

パス設定

このカテゴリの設定で、カスタムツールの場所を MERLIC 設定に追加したり、カスタムツールを MERLIC ツールライブラリ で利用できるようにしたりできます。

パスオプション

説明

ツールパス

このオプションでは、MERLIC が MERLIC のカスタムツールである HDevelop プロシージャライブラリを探す場所を定義します。MERLIC でカスタムツールを使用するには、各 HDevelop プロシージャライブラリの場所をツールパスのリストに追加する必要があります。

ボタンをクリックして、カスタムツールが入るディレクトリをツールパスに追加します。ツールパスは必要なだけ追加できます。異なる場所にほかにもカスタムツールがある場合は、各カスタムツールのディレクトリをツールパスに追加し、すべて MERLIC で利用できるようにします。

定義したツールパスのいずれかを編集するには、そのパスをクリックして必要な場所を選択するか、パスの横にある ボタンをクリックしてツールパスを削除し、新しいパスを追加します。

追加のプロシージャパス

このオプションでは、MERLIC がカスタムツールで必要とされる追加の HDevelop プロシージャを探す場所を定義します。通常、こうしたカスタムプロシージャは、複数のカスタムツールで使用される機能を含んでおり、そのため、同じ機能を複数回実装するのを避けるために別々のプロシージャに格納されています。

ボタンをクリックして、カスタムプロシージャが入るディレクトリを追加します。パスは必要なだけ追加できます。異なる場所にほかにもカスタムツールのプロシージャがある場合は、各プロシージャのディレクトリを追加プロシージャパスのリストに追加し、すべて MERLIC のカスタムツールで利用できるようにします。

定義したプロシージャパスのいずれかを編集するには、そのパスをクリックして必要な場所を選択するか、パスの横にある ボタンをクリックしてプロシージャパスを削除し、新しいパスを追加します。

このオプションは、HDevelop で使用する際にカスタムツールで必要な機能を提供する MERLIC プロシージャのみを想定しています。HDevelop のカスタムツールの実装に必要なヘルププロシージャなど、他のタイプのプロシージャは対象として想定されていません。カスタムツールの開発用に MERLIC のインストールとともに提供されるヘルププロシージャ、つまり「\examples\tool_development\procedures」サブディレクトリにあるプロシージャライブラリは、HDevelop 環境設定のプロシージャ設定で追加する必要があります。MERLIC の追加プロシージャリストには追加しないでください。

MERLIC Creator と MERLIC RTE が起動すると、定義されたツールパスから*.mvtools、*.hdpl、*.hdvp という形式のファイルが検索され、それらが読み込まれて MERLIC にツールとして統合されます。

カスタムツールを MERLIC に追加する方法の詳細については、「MERLIC ツール開発マニュアル」の「MERLIC のカスタムツールの統合」を参照してください。

プロセス統合

このタブでは、MERLIC のインメモリ結果データベースと拡張画像ストレージに関する設定を調整して、MERLIC RTE で利用可能な結果の数、MERLIC のプロセス統合モードを構成できます。

インメモリデータベース

このカテゴリでは、MERLIC RTE に保存される結果の最大数を定義できます。つまり、MERLIC Vision App を 1 回実行した結果を保存することができる反復回数を表します。結果の数が定義されたバッファサイズを超えた場合、最も古い結果が破棄されます。画像など、結果に即して格納されるデータコンポーネントについても当てはまります。

拡張画像ストレージ

このカテゴリの設定では、MERLIC RTE の拡張画像ストレージを構成できます。

オプション

説明

ディスク上の画像ストレージを拡張

このオプションを使用すると、ディスク上で MERLIC RTE の拡張画像ストレージを有効にすることができます。これを使用すると、結果の数がインメモリストレージのサイズを超えた場合、つまり、MERLIC RTE がインメモリストレージから最も古い結果の削除を開始した場合に、結果画像が引き続き利用可能であることを確認できます。

拡張画像ストレージが有効な場合、削除対象の結果により提供される結果画像は、残りの結果データと一緒に削除されるのではなく、拡張画像ストレージに移されます。したがって、それぞれの結果データが削除された後でも、画像は引き続き利用可能です。拡張ストレージに画像を追加する場合、拡張ストレージ内の画像の許容数を超えていないかどうかがチェックされ、必要であれば最も古い画像から削除されます。

最大画像数

このオプションは、拡張画像ストレージにキャッシュされる画像の数を定義します。これは、拡張画像ストレージが有効になっている場合にのみ適用されます。

結果を保存できる反復の数を参照するインメモリストレージの設定とは対照的に、このオプションは拡張画像ストレージに移動した画像の数を参照します。それぞれの結果には関連性はありません。

たとえば、2 つの画像を定義するレシピを使用する場合、そのレシピを 1 回実行すると結果には 2 つの画像が含まれるようになります。したがって、レシピを 10 回実行すると、20 の画像が作成されます。インメモリストレージのサイズがデフォルト値の 10 に設定されている場合、次の反復でストレージが超過します。拡張画像ストレージが有効になってレシピが再度実行されると、それぞれの反復の他の結果データが削除されても、最も古い結果の 2 つの画像が拡張画像ストレージに移動し、使用可能な状態が維持されます。レシピのそれ以降の実行では、最も古い結果がインメモリストレージから削除されますが、それぞれの画像は拡張画像ストレージに移動します。画像ストレージがいっぱいの場合、つまり、ストレージに許可されている数の画像がすでに含まれている場合、次の実行で最も古い画像が削除されます。

画像ストレージのパス

このオプションを使用すると、画像ストレージのデータベースのカスタムの場所とファイル名を指定できます。デフォルトでは、画像はローカルディスク上の一時フォルダに保存されます。ディスク上に十分なスペースが確保できない場合は、このオプションを使用して、画像の保存に十分なスペースがある別の場所を定義できます。