The MERLIC INI File

This page describes the general configuration file of MERLIC. It is generated with the name "MERLIC5.ini" by default. It enables you to manually configure various settings for different components of MERLIC. The configuration properties are grouped in different sections.

You can also create additional configuration files with customized settings for specific use cases. This also allows you to use multiple instances of MERLIC or MERLIC RTE with different configuration. If you want to use the configuration of an INI file, you have to start MERLIC or MERLIC RTE with the respective INI file. For more information, see Using Multiple MERLIC RTE Instances.

The following sections provide some general information such as on the location of the configuration file or how to define additional configuration files. In addition, you can find detailed information on the available configuration properties. We will refer to the configuration file in general simply as "INI file" to avoid confusion which configuration file we are referring to.

General Information

Location

On Windows, you can find the "MERLIC5.ini" file that is generated automatically in the following default directory: "C:\Users\<username>\AppData\Roaming\MVTec". You can also enter "%APPDATA%\MVTec" into your file explorer to reach that directory.

On Linux, you have to provide the INI file manually after the installation. The default "MERLIC5.ini" is expected in the following directory: "~/.config/MVTec/". For more information, see the section Providing the MERLIC5.ini File in Installing MERLIC Under Linux.

Versions

When updating to a new version of MERLIC, the backward compatibility of the INI file may be compromised. Therefore, we recommend to save a copy of your INI file and your MVApps before using them in a new version of MERLIC.

For this MERLIC version, the INI file that is generated and used by default is called "MERLIC5.ini". For previous major versions of MERLIC, a different INI file is used by default.

MERLIC version

Name of INI file

≥ 26.03

MERLIC5.ini

5.0 to 5.8

MERLIC5.ini

4.4 to 4.8

MERLIC4.ini

< 4.4

MERLIC.ini

There are two ways to find out your MERLIC version:

  • Open the "About MERLIC" dialog in the MERLIC Creator via the menu entry "Help → About".
  • Use the command line option "-V" or "‑‑version" for the MERLIC executable "merlic_creator.exe". For more information about the available command line options, see Starting the MERLIC Frontend on Windows.

Using Additional INI Files

By default, MERLIC is started with the configuration of the default "MERLIC5.ini" file. However, you can also create an additional INI file with a different configuration and then start MERLIC with the new INI file. This way, you can define different configurations for different use cases, for example, if you want to use multiple instances of MERLIC at the same time with different configurations.

To create a new INI file, you can copy the default "MERLIC5.ini", adjust the configuration as desired, and save it in any location.

To start a MERLIC with a specific INI file, you have to use the command line as described below:

  1. Open a command prompt and change to the "bin\x64-win64" directory within the MERLIC installation path, for example, "%PROGRAMFILES%\MVTec\MERLIC-26.10\bin\x64-win64".
  2. Use the command line option "‑‑ini" to specify the path and name of the INI file you want to use as shown in the example below. If the INI file does not exist, it is automatically created with this call.
    Copy
    merlic_creator.exe --ini <FILE>

The same command line option "‑‑ini" can also be used for the executable of other MERLIC applications:

  • merlic_creator.exe
  • merlic_frontend.exe
  • merlic_rte.exe
  • merlic_rte_setup.exe

For more information on how to start the respective MERLIC application, see the following pages:

Overriding the Properties in the INI File

If you start MERLIC via the command line, you have the possibility to override some properties of the INI file. You can use the available command line options to define specific settings for the current session. The specified option in the command line will override the value that is set for respective property in the INI file.

The same applies for additional INI files. If MERLIC is started with a custom INI file, the respective properties in the given INI file will override the configuration of the default "MERLIC5.ini" file.

The hierarchy of the startup options is as follows:

  1. Command line options.
  2. Options of the INI file that is specified in the command line.
  3. Options of the default "MERLIC5.ini" file.
  4. If no INI file exists, MERLIC will create one in the default directory or in the directory that was defined in the command line during the start.

Structure and Encoding

The INI file is structured in different sections that contain the settings for the respective component. The sections are added chronologically and may be reorganized automatically by MERLIC. The names of the sections are specified in square brackets [ ] in the INI file. When editing the INI file manually, you can add new sections anywhere above or below existing sections.

The INI file requires an UTF-8 character encoding on all platforms. It is possible to use regular slashes "/" and backslashes "\" as path separators in the INI file. Lines starting with "#" are ignored by MERLIC.

Sections

In the following, you can find detailed information on the available sections and properties for the INI file. Currently, you may define properties in the following sections:

[General]

Property

Default

Description

GuiLanguage

 

This option allows you to change the language of the user interface. By default, MERLIC uses the language that has been selected in the installation process of MERLIC.

The following languages are available:

  • de_DE: German
  • en_US: English
  • ja_JP: Japanese
  • zh_CN: Simplified Chinese

The MERLIC Frontend offers additional language options. For information about setting the language of the Frontend, see Changing the Language of the MERLIC Frontend.

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Language"

For more information, see MERLIC Preferences.

HalconDisableCudnnOptimization

true

This property can be used to enable or disable the dynamic optimizations via the NVIDIA® CUDA® Deep Neural Network library (cuDNN).

This optimization refers to MERLIC tools with deep learning technology, for example, Detect Anomalies. By default, this property is set to "true" which means that no additional optimization is performed.

If it is set to "false", additional optimizations are performed when selecting a GPU as processing unit in a MERLIC tool. Depending on the capabilities of the selected GPU, the enabled optimization might take significantly more time, but it usually leads to better inference performance and thus, decreasing cycle times. With the optimization, the duration required for the following processes will be improved:

  • Loading MVApps that contain MERLIC tools with deep learning technology
  • When configuring a MERLIC tool with deep learning technology:
    • Applying the training data, provided a training mode is available for the tool
    • Selecting a different model file
    • Setting the processing unit to a GPU

If you want to use the cuDNN optimization, make sure to update the driver of your GPU to the latest version. Otherwise, the optimization via the cuDNN library might not be supported. If this setting is changed, MERLIC needs to be restarted.

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Disable optimization of models"

For more information, see MERLIC Preferences.

HDevelopDebugPort

57786

This property defines the HDevelop debug port that is used to connect to MERLIC to debug custom tools in a special debug mode of HDevelop.

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → Custom Tools → HDevelop debug port"

For more information, see MERLIC Preferences.

HDevelopDebugServer

false

This property defines whether the HDevelop debug server that is required to debug custom MERLIC tools in a special debug mode of HDevelop is activated. You can set the following values:

  • true: The HDevelop debug server is started automatically on startup of MERLIC.
  • false: The HDevelop debug server is deactivated.
GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → Custom Tools → Enable HDevelop remote debugging"

For more information, see MERLIC Preferences.

IniVersion

4

This property is used by MERLIC to determine valid keys and values. For the current MERLIC version, it must be set to 4.

LineWidth

2 [px]

This property stores the width of lines that are visualized in MERLIC. It is defined in pixel.

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Line width"

For more information, see MERLIC Preferences.

MainWindowGeometry

 

This property stores the position and appearance of the MERLIC Creator window in a ByteArray.

MainWindowMaximized

false

This property defines if the MERLIC Creator window is maximized when opened. You can set the following values:

  • true: The window is maximized.
  • false: The window is not maximized.

MainWindowState

 

This property stores the appearance and state of the components in the MERLIC Creator window in a ByteArray.

For more information about personalizing your user interface, see MERLIC Preferences.

OpenUpdateDialog

true

This property defines if the dialog that notifies the user about an available update for MERLIC is shown upon startup. It is possible to disable the notifications, however it is not possible to disable the check for available updates. You can set the following values:

  • true: If an update is available, the update dialog is shown upon startup.
  • false: If an update is available, the update dialog is not shown upon startup.
GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Show dialog in case of a new update"

For more information, see MERLIC Preferences.

ProceduresPath

<empty>

This property can be used to define the location of your custom MERLIC procedures (*.hdpl). The location must be defined as an absolute file path to the HDevelop procedure. If you want to specify multiple procedure paths, you can define the paths in a semicolon-separated list.

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → Custom Tools → Additional procedure path"

For more information, see MERLIC Preferences.

ShowStartupDialog

true

This property defines if the start dialog in the MERLIC Creator is shown upon startup. It is possible to disable the start dialog. You can set the following values:

  • true: The start dialog is shown upon startup.
  • false: The start dialog is not shown upon startup.

For more information about the start dialog and personalizing your user interface see Start Dialog and MERLIC Preferences.

StartServer

true

The following property defines if a server should be started. It is necessary to start a server for using MERLIC with process integration and a remote Frontend. You can set the following values:

  • true: The server is activated during the initialization of MERLIC. The respective server settings must be defined in the section [Server].
  • false: The server is not activated during the initialization of MERLIC.

StartupDialogState

 

This property stores whether in the start dialog the sections "Recent MVApps" and "Examples" are expanded or collapsed as well as the position of the splitter between the two sections.

ToolPath

<empty>

This property can be used to define the location of your custom MERLIC tools. The location must be defined as an absolute file path to the HDevelop procedure representing the custom tool. If you want to specify multiple tool paths, you can define the paths in a semicolon-separated list. MERLIC will then search the defined paths for files of the formats *.mvtools, *.hdpl and *.hdvp. Files of these formats will be loaded and integrated into MERLIC.

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → Custom Tools → Tool Paths"

For more information, see MERLIC Preferences.

VisualizeSkippedTools

 

This property allows you to choose whether MERLIC highlights the tools that were not executed in the last iteration. You can set the following values:

  • true: The highlighting is activated.
  • false: The highlighting is deactivated.
GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Highlight tools that were not executed"

For more information, see Tool Flow.

[colors]

The properties in this section define the colors used in MERLIC to visualize the various tools and widgets in MERLIC..

Color values are either expressed as values in hexadecimal format or as named colors following to the HTML standard. User defined colors are possible. In this case, the settings "key" and "value" are the same.

Value

Description

accepted

This color is used for the easyTouch preview in MERLIC tools with a training mode such as the matching tools or code reading tools. When using easyTouch in a training image to find a suitable object or code for the training, easyTouch provides visual feedback on whether the image part within the currently selected area is suitable for the training by coloring the border accordingly. If the image part is suitable, the border is displayed in the color defined for "accepted".

This color is also used in some MERLIC tools without training mode to highlight regions or contours that fit the current parameter settings of the tool, for example, for the accepted regions in the tool Evaluate Regions.

easy_touch

This color is used for easyTouch to highlight the preliminary results that can be previewed before confirming your choice with a mouse click.

fail

This color is used for easyTouch in MERLIC tools for code reading. When hovering the mouse pointer over an area in which the decoding failed, the border of this area is highlighted in this color.

ok

This color is used for easyTouch to highlight the regions or contours that were selected via easyTouch with a mouse click.

region_input

This color is used to highlight the border of input regions that are transmitted from a previous tool.

rejected

This color is used for the easyTouch preview in MERLIC tools with a training mode such as the matching tools or code reading tools. When using easyTouch in a training image to find a suitable object or code for the training, easyTouch provides visual feedback on whether the image part within the currently selected area is suitable for the training by coloring the border accordingly. If the image part is not suitable, the border is displayed in the color defined for "rejected".

This color is also used in some MERLIC tools without training mode to highlight regions or contours that do not fit the current parameter settings of the tool, for example, for the rejected regions in the tool Evaluate Regions.

roi_active

This color is used for the region of interest (ROI) that is currently selected.

roi_inactive

This color is used for the regions of interest (ROIs) that are currently not selected.

warning

This color is used for the easyTouch preview in MERLIC tools with a training mode such as the matching tools or code reading tools. When using easyTouch in a training image to find a suitable object or code for the training, easyTouch provides visual feedback on whether the image part within the currently selected area is suitable for the training by coloring the border accordingly. If the data within the image part is not sufficient for a good result, the border is displayed in the color defined for "warning".

GUI Settings

The colors can also be configured in the MERLIC Creator: "Edit → Preferences → Colors".

For more information, see MERLIC Preferences.

[Communicator]

The properties in this section can be used to configure specific settings for communication plugins. For more information, see Additional Settings for Communication Plugins.

Property

Default

Description

CommandTimeout

5000 [ms]

This property defines the timeout in milliseconds for commands sent by communication plugins in case MERLIC RTE is not responding.

ConfigDir

Windows:

%AppData%\MVTec\Communicator\conf\

Linux:

"~/.config/MVTec/Communicator/conf"

This property defines the directory for the JSON configuration files of communication plugins.

For more information, see Additional Settings for Communication Plugins.

PluginDir

 

This property defines the directories where to look for communication plugins. The directories can be defined in a semicolon-separated list.

This setting is required if you implemented your own communication plugin and placed the respective plugin library in a different location than the communication plugins provided by MERLIC.

Make sure to specify all directories in which communication plugins are located, including the default location of the MERLIC communication plugins.

If the same plugin name occurs in multiple directories, the order in which the directories appear in the list determines the precedence.

By default, the communication plugins are searched in the directory where the MERLIC executable files are located:

  • %PROGRAMFILES%\MVTec\MERLIC-26.10 (Windows installation with administrator rights)
  • %LOCALAPPDATA%\Programs\MVTec\MERLIC-26.10 (Windows installations without administrator rights)

For more information, see Additional Settings for Communication Plugins.

[Designer]

This section contains properties for the workspace of the MERLIC Designer. These settings can also be adjusted in the graphical user interface of the MERLIC Designer.

Property

Default

Description

GridColor

#ffff00

This property defines the color of the grid. If you set the color in the INI file, you have to use the respective hexadecimal value. However, the color can also be set in the graphical user interface of the MERLIC Designer in the menu "Edit → Grid Properties".

GridSize

20

This property defines the size of the grid in pixels. The size can also be set in the graphical user interface of the MERLIC Designer in the menu "Edit → Grid Properties".

ShowGrid

true

This property defines whether the grid is shown in the workspace or not. To deactivate the grid, set the property to "false". Alternatively, you can also change this setting via the graphical user interface of the MERLIC Designer using the menu entry "Edit → Show Grid".

SnapToGrid

true

This property defines whether the widgets are snapped to the grid when moving them to a new position. To deactivate this mode, set the property to "false". Alternatively, you can also change this setting via the graphical user interface of the MERLIC Designer using the menu entry "Edit → Snap to Grid".

GUI Settings

The grids can also be configured in the Frontend Designer via the menu bar or the "Edit" menu: "Edit → Grid Properties"

For more information, see Personalize the User Interface.

[Frontend]

This section contains properties for the MERLIC Frontend and for connections between MERLIC Frontend and MERLIC Creator or MERLIC RTE, respectively. The MERLIC Frontend connects to MERLIC Creator or MERLIC RTE instances via the MERLIC server component. MERLIC server and MERLIC Frontend communicate via inter process communication.

Connection Settings

You can configure the following Frontend properties. Each of the properties has a predefined default value which is used if no value is specified in the INI file or as command line argument:

Property

Default

Description

CycleTime

50 [ms]

The MERLIC Frontend continuously polls the MERLIC server for new data. The "CycleTime" property defines the minimum interval between two polling requests. It is defined in milliseconds.

This can be used to throttle the MERLIC Frontend and reduce the work load of the MERLIC server.

GuiLanguage

 

This property can be used to set the language in which the MERLIC Frontend shall be started, for example, "en_US".

ReconnectInterval

25 [s]

This property is used when the connection to the Frontend server has been lost. Initially, the Frontend will attempt to reconnect once. If this fails, a reconnection is attempted in a specific time interval which is defined in "ReconnectInterval". It defines the time (in seconds) that will pass until a reconnection is attempted. If it is set to 0, the Frontend will attempt to reconnect as fast as possible.

Url

 

This property can be used to connect the MERLIC Frontend directly to a specific MERLIC instance on a specific system. When starting the MERLIC Frontend, it will automatically try to connect to the respective system and you do not have to select the MERLIC instance manually via the "Select instances" dialog.

You can specify the URL for the desired system and MERLIC instance with the following supported formats:

  • ws[s]://<HOST>[:<PORT>]/instances/<INSTANCE_NAME>
  • unix:///<PATH_TO_INSTANCE>/me-<INSTANCE_NAME>
  • tcp://<HOST>:<PORT> (legacy)

The URL can also be specified when starting the MERLIC Frontend via command line by using the command line option "‑‑url". In this case, the URL setting in the INI file will be ignored and the MERLIC Frontend connects to the system and MERLIC instance defined in the command line. For more information, see Starting the MERLIC Frontend on Windows and Connecting the MERLIC Frontend to a Remote Server.

The format with the "tcp" scheme is legacy and supported only for use with MERLIC version 26.03 or older. It might be removed in future MERLIC versions.

Customization and Miscellaneous Settings

In addition, you can configure the following properties for the Frontend:

Property

Default

Description

AlwaysShowROIHandles

false

This property is specifically included for devices with a touch screen to facilitate the usage of ROIs. The property is useful if the Image Display widget in your MERLIC Frontend also shows a region of interest (ROI). It defines if the interaction handles of the ROI are always shown (true) or not (false).

HideMVTecMerlicInFrontendWindow

false

This property defines whether the name of MVTec and MERLIC is visible in the window title of the Frontend and in the status message that is shown in the Frontend while loading the Frontend design. To hide company and product name, set the property to "true". As soon as the Frontend has been loaded, the window title that is defined in the "Frontend Properties" of the MERLIC Designer will be shown.

HideWindowTitleBar

false

If set to "true" the MERLIC Frontend will start without showing the title bar of the application window. This will also affect the keyboard shortcuts that can be used, e.g., to close the window.

IconFile

 

This property can be used to define a custom icon for the Frontend. It will be shown in the window title bar and the task bar instead of the default MERLIC icon. You have to define the absolute path and file name of the icon.

ROIHandleSize_mm

4 [mm]

This property is specifically included for devices with a touch screen to facilitate the usage of ROIs. The property is useful if the Image Display widget in your MERLIC Frontend also shows a region of interest (ROI). It defines the size of the interaction handles of the ROI. It is defined in millimeters.

StartInFullscreen

false

This property defines whether the MERLIC Frontend is started in full screen mode. If you want to display the Frontend automatically in full screen mode each time you start it, you can set this option to "true". If you want to use this option only for a single session, you can start the Frontend via command line with the option "‑‑fullscreen".

TmpPath

%AppData%\Local\Temp\<user_group>_<user_name>

The MERLIC Frontend requires access to a writable directory on the hard disk of your computer to temporarily store files. You can set the path to the directory using the "TmpPath" property. If the directory does not exist, MERLIC will try to create the directory.

You can use slashes (/), backslashes (\) or double backslashes (\\) for file paths in MERLIC INI files. However, MERLIC will internally store the paths with slashes (/).

WindowGeometry

 

This property can be used to specify the position and size of the MERLIC Frontend as follows: @Rect(x y w h)

The values x and y define the position of the upper left corner of the MERLIC Frontend. The values w and h define the width and height of the MERLIC Frontend. All values must be given in pixels. If the property "StartInFullscreen" is set to "true", the MERLIC Frontend will be opened in full screen mode and the setting for "WindowGeometry" will be ignored.

For more information about the settings of the Frontend or the required settings for starting a remote Frontend, see the following pages:

Legacy Settings

The following INI properties for the [Frontend] section are legacy and only provided for compatibility with previous MERLIC versions.

Property

Default

Description

Host

127.0.0.1

This property is used to set a hostname or an IP address. Thus you may configure to which computer the Frontend shall be connected.

This option is legacy and provided only for use with MERLIC version 26.03 or older. It might be removed in future MERLIC version. We recommend using the "Url" option to specify the desired MERLIC server, the MERLIC Frontend should connect to.

Port

9090

This property defines the TCP/IP port to which the server listens.

This option is legacy and provided only for use with MERLIC version 26.03 or older. It might be removed in future MERLIC version. We recommend using the "Url" option to specify the desired MERLIC server, the MERLIC Frontend should connect to.

[Logging]

This section contains properties regarding the path, size, and number of log files, as well as the message threshold. For more information about the configuration including logging information for MERLIC with process integration, see Logging.

Property

Default

Description

LogFilePath

%LOCALAPPDATA%\MVTec\MERLIC\

This property defines the path to the directory in which the log file is stored.

You can use slashes (/), backslashes (\) or double backslashes (\\) for file paths in MERLIC INI files. However, MERLIC will internally store the paths with slashes (/).

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Log file path"

For more information, see MERLIC Preferences.

LogFileSizeInBytes

10 485 760 (= 10 MB)

This property defines the maximum size of the log files in bytes. If the maximum size of the log file is reached and the property "LogFilesCount" > 1, MERLIC will start to log the new messages into a new file. In case the maximum number of allowed log files is reached, MERLIC will start to overwrite the oldest messages.

Minimum value: 1 048 576 = 1 MB

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Maximum size of log files"

For more information, see MERLIC Preferences.

LogFilesCount

10

This property defines the maximum number of log files that are kept in the log file directory. If the maximum size is reached for each log file, MERLIC will delete older log files.

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Maximum number of log files"

For more information, see MERLIC Preferences.

Threshold

info

This property defines the used log level. Logging of messages of a given level generally includes the logging of all messages of stricter levels. The available log levels are the following:

  • none: No messages are logged.
  • critical: Messages of severity "critical" contain information on errors that cause MERLIC to crash.
  • error: Messages of severity "error" contain information on errors, e.g., for MERLIC tools. If this log level is selected, also the messages of severity "critical" are logged.
  • warning: Messages of severity "warning" contain information that indicate a problem, e.g., at a MERLIC tool. If this log level is selected, also the messages of severity "critical" and "error" are logged.
  • info: Messages of severity "info" contain general non-critical information. If this log level is selected, also the messages of severity "critical", "error", and "warning" are logged.
  • trace: Messages of severity "trace" contain detailed information that might be useful to understand the context of warnings or error messages. If this log level is selected, also the messages of severity "critical", "error", "warning", and "info" are logged.
GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → General → Minimum log level"

For more information, see MERLIC Preferences.

[ProcessIntegration]

Property

Default

Description

DefaultRecipe

 

This property defines the index of the recipe file that is loaded automatically if MERLIC is started with process integration, i.e., from the command line with "merlic_rte.exe". If this option is not defined, the recipe must be loaded by the PLC.

GUI setting

This property can also be configured in the MERLIC RTE Setup.

For more information, see Defining the Default Recipe.

InstanceName

 

This property can be used to assign a name to the MERLIC RTE instance. This way, a MERLIC RTE instance can be easily identified, especially when running multiple MERLIC RTE instances. The instance name is also required when connecting a MERLIC Frontend or MERLIC RTE Setup to the respective MERLIC RTE instance.

The specified name is currently also applied to MERLIC Creator instances.

The name can be set to any string. If no instance name is set, a UUID (universally unique identifier) string, for example, 547d1842-3ab2-477f-a430-0b05fe3cb0dc, will be randomly generated to ensure that the identifier is unique.

The instance name is written to the regular MERLIC log, as part of the initial log line.

It is not possible to run two MERLIC instances with the same instance name under the same user account. If you want specify instance names via the INI files, you have to make sure to start each MERLIC instance with its own INI file and that the respective instance names defined in the INI files differ. Otherwise, an error occurs when starting the second MERLIC instance.

LocalImageStorePath

 

This property allows you to specify a custom location and file name for the database of the extended image storage. By default, the images are stored in a temporary folder on the local disk. If not enough space is available on your disk, you can use this property to define a different location with enough space for the image storage. It only applies if the extended image storage is enabled via "UseLocalImageStore".

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → Process Integration → Path of image storage"

For more information, see MERLIC Preferences.

LocalImageStoreSize

100

This property defines the number of images that will be cached in the extended image storage. It only applies if the extended image storage is enabled via "UseLocalImageStore".

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → Process Integration → Maximum number of images"

For more information, see MERLIC Preferences.

ResultBufferSize

10

This property defines the maximum number of results that are stored for the process integration. Thus, it represents the number of iterations for which the results of a MERLIC Vision App execution can be stored. If the number of results exceeds the buffer size, the oldest results will be discarded. The same applies to data components stored along the results.

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → Process Integration → Maximum number of results"

For more information, see MERLIC Preferences.

RTEStartupISMConfiguration

 

This property can be used to define the ISM configuration that shall be used as RTE startup configuration. The defined ISM configuration is automatically loaded and activated when MERLIC RTE starts.

GUI setting

This property can also be configured in the MERLIC Runtime Environment Setup:

"Image Sources → Use as RTE startup configuration"

For more information, see Basic Terms and Concepts and Adding New Configurations and Image Sources.

UseLocalImageStore

false

This property defines whether an extended image storage is used for MERLIC RTE. It can be used to ensure that result images will still be available when the number of results exceeds the size of the in-memory storage defined in "ResultBufferSize", that is, when MERLIC RTE starts removing the oldest results from the in-memory storage. To enable extended image storage, you have to set the value to "true".

GUI setting

This property can also be configured in the MERLIC Creator:

"Edit → Preferences → Process Integration → Extend storage of images on disk"

For more information, see MERLIC Preferences.

Optional Properties

Property

Description

Device<n>

This property stores the device you defined in the "I/O" tab of MERLIC RTE Setup that is used for communication with the PLC.

This property stores additional information about the hardware you have configured. The information is used to properly display the device in the GUI while the hardware is not connected.

Recipe<n>

This property stores the name and absolute path of the MERLIC recipe files A MERLIC recipe represents a file with file ending ".mrcp", which references a specific MERLIC Vision App (MVApp) with a specific MVApp configuration. In MERLIC RTE, the process integration mode of MERLIC, recipes are used to load the referenced MVApp with the configuration as specified in the recipe. MERLIC recipes are only required if you want to set up mulitple pre-defined MVApp parameterizations for the same MVApp, or if you want to aktivate and use a specific acquisition sequence when loading an MVApp in MERLIC RTE (.mrcp) or the MVApp files (.mvapp) that are available for MERLIC RTE. When importing a recipe or MVApp in the "Recipes" tab of the MERLIC RTE Setup, the respective entries are automatically added to the INI file.

The property identifier "Recipe" is to be followed by an index number, starting from 0: "Recipe<n>". The index number represents the respective recipe ID. The recipe IDs can also be changed by sorting the imported files in the "Recipes" tab of the MERLIC RTE Setup.

For more information, see MERLIC Recipe Files and Importing MVApps and Recipes for MERLIC RTE.

[RecentlyWorkedOn]

This section contains a list of up to 10 MVApps you opened most recently. You can access the MVApps in the MERLIC Creator via "File → Recently Opened".

[RTESetup]

This section contains settings for the MERLIC Runtime Environment Setup (MERLIC RTE Setup).

Property

Default

Description

Url

 

This property can be used to connect the MERLIC RTE Setup directly to a specific MERLIC instance on a specific system. When starting the MERLIC RTE Setup, it will automatically try to connect to the respective system and you do not have to select the MERLIC instance manually via the "Select instances" dialog.

You can specify the URL for the desired system and MERLIC instance with the following supported formats:

  • ws[s]://<HOST>[:<PORT>]/instances/<INSTANCE_NAME>
  • unix:///<PATH_TO_INSTANCE>/me-<INSTANCE_NAME>

The URL can also be specified when starting the MERLIC RTE Setup via command line by using the command line option "‑‑url". In this case, the URL setting in the INI file will be ignored and the MERLIC RTE Setup connects to the system and MERLIC instance defined in the command line.

WindowGeometry

 

This property can be used to specify the position and size of the MERLIC RTE Setup as follows: @Rect(x y w h)

The values x and y define the position of the upper left corner of the MERLIC RTE Setup. The values w and h define the width and height of the MERLIC RTE Setup. All values must be given in pixels. If the property "WindowMaximized" is set to "true", the MERLIC RTE Setup will be opened in full screen mode and the setting for "WindowGeometry" will be ignored.

WindowMaximized

true

This property defines if the MERLIC RTE Setup window is maximized when opened. You can set the following values:

  • true: The window is maximized.
  • false: The window is not maximized.

[Server]

If the server is activated via the "StartServer" property in the [General] section, the settings for the server must be added to the section [Server]. The following settings are available:

Property

Default

Description

AnonymizeFrontendLog

false

This property can be used to define if the logged data is stored together with the corresponding user who made the changes. If it is set to "false", the user name is also logged. If it is set to "true", the data is logged without any user information.

MaxConnections

10

This property sets the maximum number of allowed simultaneous connected MERLIC Frontends.

WriteLockTimeout

10000 [ms]

This property sets the duration for the write lock of a MERLIC Frontend that is activated when a user interaction in a concurrent MERLIC Frontend has been finished.
If multiple MERLIC Frontends are used simultaneously and a user performs any interaction within a MERLIC Frontend, all other MERLIC Frontends will be locked. When the user stops interacting in the MERLIC Frontend, the counter of "WriteLockTimeout" starts. In case of another user interaction, the write-permission is automatically renewed. If no further user interaction takes place during this time, the permission for modifying parameters can again be requested by any other connected MERLIC Frontend.

Legacy Settings

The following INI properties for the [Server] section are legacy and only provided for compatibility with previous MERLIC versions.

Property

Default

Description

TcpHost

 

This property defines the local IP address on which the MERLICServer listens for Frontends to connect. By default, no value is set and the server listens on all network interfaces for IPv4 and IPv6 connections.

If the host is set to 0.0.0.0, only IPv4 is available. If it is set to localhost or 127.0.0.1, the server only listens for locally running Frontends to connect.

This option is legacy and provided only for use with MERLIC version 26.03 or older. It might be removed in future MERLIC version. We recommend using the "Url" option in the [Frontend] category to specify the desired MERLIC server, the MERLIC Frontend should connect to.

TcpPortMax

9099

This property determines the maximum port of a range of ports the server should listen for Frontends to connect. Normally the server listens on "TcpPortMin". In case this port is already used by another application, MERLIC server uses the next available port within the defined range up to "TcpPortMax".
If ports should not be adapted automatically, "TcpPortMax" can be set equal to "TcpPortMin". In case the single port is not available, no TCP connection is possible.

This option is legacy and provided only for use with MERLIC version 26.03 or older. It might be removed in future MERLIC version. We recommend using the "Url" option in the [Frontend] category to specify the desired MERLIC server, the MERLIC Frontend should connect to.

TcpPortMin

9090

This property determines the minimum port of a range of ports the server should listen for Frontends to connect.

Normally the server listens on "TcpPortMin". In case this port is already used by another application, the MERLICServer uses the next available port within the defined range up to "TcpPortMax".

This option is legacy and provided only for use with MERLIC version 26.03 or older. It might be removed in future MERLIC version. We recommend using the "Url" option in the [Frontend] category to specify the desired MERLIC server, the MERLIC Frontend should connect to.

[UserManagement]

This section defines the look of the user management window in the MERLIC Designer.

Property

Default

Description

SplitterPosition

280

This property defines the position of the splitter control that divides the list view on the left side and the properties view on the right side of the MERLIC User Management dialog.

Window

Rect(100 100 1024 768)

This property defines the position and size of the MERLIC User Management dialog.

For more information about the user management, see Setting up the User Management.